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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

♦ The ♦ symbol indicates that the following text highlights a specific benefit 
of Lookout.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Introduction to Lookout

National Instruments Lookout is a full-featured object-based HMI/SCADA 
software system that delivers unparalleled power and ease of use in 
demanding industrial measurement and automation applications.

Why Choose Lookout?
To develop any application in Lookout, you simply create objects and 
connect them—no programming, scripting, or compiling is required. 
Lookout offers a host of capabilities like multi-client/multi-server 
networking, Web monitoring and control, OPC server and client, security, 
and distributed logging and alarms.

Object-Oriented Architecture
With Lookout, you can create a process in three basic steps. First, you 
select the type of object you want to create from Lookout’s large library 
of control, driver, display, and data manipulation objects. Second, you 
configure the object using Lookout’s enhanced tools. Finally, you connect 
the objects. You can create direct connections, remote connections, or 
complex connections that test logical conditions or perform calculations.
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When you create objects, you choose from Lookout’s extensive library 
of controls, displays, ActiveX controls, and hardware drivers. Each driver 
object you create is ready to read from and write to the field hardware 
connected to your computer. And with the Aggregate object, you can 
even create a basic process to reuse within other processes, which saves 
you time.

Event-Driven Performance
Events drive Lookout, which means that Lookout is notified immediately 
when a change occurs. Lookout reacts to events substantially faster than 
loop-based software.

Online Configuration
You can develop and modify a Lookout process while your application is 
running. This online configuration means that there are no gaps in your 
data, alarm, and event records when you do maintenance.

Multi-Server and Multi-Client Networking
You can connect any number of computers running Lookout server and 
client processes. The TCP/IP networking protocol integrated into Lookout 
makes networking as easy as dragging a data point to a control panel 
display or typing in a URL.

Redundancy Capabilities
Lookout comes with advanced objects that you can easily use to create 
emergency backup systems to take over in case of system failures. You also 
can use objects to create and run a multitude of processes from a single 
process template—all done the easy Lookout way.

Web Capabilities
With the Web Client feature of Lookout, you can monitor and control a 
Lookout process from any computer connected to the Internet. In seconds, 
you can create a basic HTML page by following the simple export 
procedure in Lookout. You can then access your client process through 
Microsoft’s Internet Explorer. You also can create an HTML report page 
for viewing only.
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Graphics and Visualization
You can use graphics to visually demonstrate the process on your control 
panels. Lookout includes an extensive library of graphics, including both 
static pictures and animated figures, which can enhance your processes by 
graphically representing your system and the changes that occur. For added 
customizing, you can import your own graphics such as AutoCad files or 
photographs. Lookout supports .wmf and .bmp files.

Security
Lookout lets you set up to ten security levels, with varying levels of read or 
write access based on those security levels. You can use the security 
features to restrict panel retrieval and viewing, individual object control, 
and whether Lookout can be closed or minimized. You have the flexibility 
to limit group and user access, as well as access to folders and specific 
objects. You can even restrict access on the basis of IP address.

Distributed Alarms and Events
Any computer running Lookout can monitor alarms and events generated 
by any Lookout process. You can use ten priority levels to group and filter 
alarms and events, which gives you the power to focus on what is most 
important in a given circumstance. A single keystroke acknowledges 
alarms from any computer on the network. In addition, Lookout includes 
the following alarm and event reporting capabilities:

• Play voice messages using .wav files

• Define alarm/event reporting for each object

• Print alarm/event reports

• Log distributed alarm/event information

• Send email or alert a pager on alarm conditions

• Create an audit trail using an event log
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Distributed Data Logging
Lookout logs alarms, events, and data to its internal database, called 
Citadel. The Citadel historical database is the highest-performing real-time 
historical solution currently available in the market. The logging 
capabilities of Lookout allow you to do the following:

• Log data from any computer running Lookout on your network, to any 
other computer running Lookout on your network

• Log data to spreadsheet files or to other applications using Dynamic 
Data Exchange (DDE)

• Retrieve logged data using SQL queries into Citadel

• Execute any SQL statement on a third-party database with ODBC 
connectivity

• Log data at regular intervals, on demand, on occurrence of an event, 
or in any combination of these criteria

• Maintain the history of your processes accurately and automatically

Trends and Charts
Lookout allows you to display graphical data from a number of different 
sources at one time. You also can create groups, each one having its own 
data set and its own scaling and time constraints. You can plot as many 
numeric (analog) and logical values as you want, and even embed trend 
charts in a Web browser.

Report Generation
With Lookout, you can create custom reports using your favorite 
spreadsheet package. You can configure Lookout to create automatic 
scheduling and on-demand reports. It also is possible to view HTML 
reports generated by Lookout using a Web browser.

Telemetry
Lookout allows multiple protocols to share the same serial port and, 
therefore, the same radio frequency. For instance, you can have different 
manufacturers’ PLCs (Programmable Logic Controllers) and RTUs 
(Remote Terminal Units) using different communications protocols on 
the same line using one modem.
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Hardware Connectivity
Lookout offers seamless integration with National Instruments hardware, 
such as FieldPoint and Data Acquisition (DAQ) products. Lookout also has 
dozens of custom drivers to help you control PLCs and RTUs from a wide 
variety of manufacturers. Lookout is a fully-compliant OPC (OLE for 
Process Control) client and server, allowing full connectivity through 
the industry standard for open multivendor connectivity. Lookout is 
compatible with the OPC Data Access 1.0a and 2.03 specifications.

Flexible Purchase Options
For your convenience, Lookout software is available in 
development/runtime or runtime-only versions, with different options 
for the number of I/O connections. You can purchase client software 
(runtime-only client software is free) or add as many client licenses as 
you need. A developer toolkit also is available.

World-Class Technical Support
To ensure your success, we are committed to providing you with services 
around the globe to achieve the best results from our products for years to 
come. Our services and support options include hardware and software 
services, customer support, customer education, and professional services 
for consulting or integration. You can find detailed information about these 
resources in Appendix A, Technical Support and Professional Services, 
and at ni.com/support.
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2
Installation

This chapter describes the system requirements for the Lookout software 
and contains installation instructions.

System Requirements
Make sure you have the following minimum components in place before 
you attempt to install and use Lookout.

• Pentium class or equivalent PC running at 90 MHz or faster.

• At least 32 MB RAM.

• 95 MB free disk space, plus possibly 100 MB or more, depending 
on how much historical data you intend to log to the Citadel historical 
database; you also should have about 50 MB of disk space for file 
swapping on Windows 2000/NT/XP computers.

• Windows 2000, Windows NT version 4.0 or later, Windows XP, or 
Windows Me/98; National Instruments strongly recommends using 
Windows 2000/NT/XP for optimum stability.

• Monitor display setting of at least 800 × 600 pixels.

• If you want to create a Web Client, your computer must have Microsoft 
Internet Explorer, version 3.2 or later.

• If you want to explore Lookout networking capabilities (as shown in 
the Networking the Client Process exercise of Chapter 3, Try Out 
Lookout), you need a network card and TCP/IP networking installed 
on the computers you want to connect. You also need access to a 
second computer on your network that meets all of the above 
requirements.
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Software Installation
Complete the following steps to install the Lookout software.

1. Shut down all applications that may currently be using ODBC such as 
spreadsheets, word processors, database programs, MS Query, and 
similar applications.

2. Run the Lookout setup program.

• If you have a CD, insert it into your CD drive. The Lookout 
CD-ROM has autorun capability. If for some reason the autorun 
fails to start the CD installation routine, click the Start icon in the 
taskbar and select Run. Enter N:\Lookout\setup.exe where 
N represents your CD-ROM drive. Then click OK.

• If you downloaded the software to your computer from the 
Internet, double-click the lk50_eval.exe file at that location on 
your computer.

Choosing a custom installation provides you with certain installation 
options, including the following:

• Lookout allows you to choose whether to install its online help. 
Use Browse to enter the name of an alternate directory or click 
Next to accept the recommended directory name.

• During installation, Lookout can install its ODBC driver. Make 
sure you select the Citadel ODBC option if you want to be able 
to access Lookout’s Citadel database.

• When installing Lookout on a Windows 2000/NT/XP system, you 
are presented with a list of options on what you may install. Make 
sure you install the optional NT keyboard driver under 
Windows NT if you want to be able to block unauthorized users 
from using certain keyboard commands such as <Alt-Tab> to 
switch out of Lookout.

3. Follow the remaining instructions to complete the Lookout 
installation.

Limitations of the Evaluation Software
The evaluation copy of Lookout allows you to have up to ten I/O points and 
two client connections. You can run evaluation copies of Lookout on as 
many computers on your network as you like. Your evaluation copy will 
run for two hours at a time. Before Lookout shuts down, you will be given 
the opportunity to save your process. The Lookout evaluation software has 
no expiration date.
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3
Try Out Lookout

This chapter introduces you to example applications and guides you 
through the following Lookout activities: creating a server process and 
client process, experimenting with the Web Client, and networking the 
client process. The following illustration shows how your Lookout screen 
might look when you complete the exercises.

 

1 Active Process Name
2 Title Bar
3 Control Panel
4 Active Alarm/Event Count

5 Control Panel Navigation Arrows
6 Status Bar
7 Alarm Window
8 Minimized Control Panel

9 Object Explorer
10 Root Window
11 Lookout Menu

6

2 31

5 4

7

8

9

10

11
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♦ Lookout handles discrete, batch, and continuous processes.

♦ Lookout can handle an unlimited number of objects, I/O points, 
and graphic panels.

Viewing the Application Examples
Lookout is used to brew beer, process food, run chemical plants, operate 
oil and gas pipelines, automate buildings, control energy management 
systems, bottle soft drinks, operate power plants, and operate municipal 
water supplies. The examples that install with Lookout demonstrate the 
kind of applications Lookout is capable of producing. Complete the 
following steps to view the examples.

1. Launch Lookout by selecting Start»Programs»National 
Instruments Lookout.

2. Select File»Open, and open home2 in the Examples folder.

3. Use the links in home2 to browse the Application Examples.

4. When you are done, select File»Exit and click Yes to stop any 
processes that are running.

Creating a Server Process and Client Process
A typical Lookout application is developed with a client/server design for 
strength and flexibility. The server process uses direct connections from the 
computer running it to the hardware it is controlling and monitoring. It runs 
on one computer all the time; it is not intended to be mobile. Client 
processes connect to a server process and are capable of running on any 
computer on your network, even the server computer. The following 
illustration shows an example of a client/server configuration.
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Create a Server Process
In this exercise, you simulate connections to hardware. You will use this 
process as the server process in later exercises.

Note While server is a networking term, a Lookout server process does not necessarily 
need to be connected to a network.

This exercise shows how easy it is to create and configure Lookout objects, 
make and edit connections between those objects, and configure data for 
logging.

1. Start Lookout by selecting Start»Programs»National Instruments 
Lookout. Lookout launches and displays a dialog box describing the 
evaluation version. Even though the evaluation software runs for only 
two hours at a time, you can always save your work and open your files 
again if Lookout shuts down. 

2. Browse the information offered in the default process by clicking the 
topic links.

Client

Server/Client

Client

Client
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3. Close the default process by selecting File»Close All. Click Yes to 
stop the process.

4. Select File»New to create a new Lookout process.

Notice that the status bar at the bottom of the Lookout workspace is 
now yellow. This signals that Lookout is in edit mode. If you have 
trouble completing any of the steps in the evaluation exercise, check to 
see whether Lookout is in edit or run mode. You can change modes by 
pressing <Ctrl-Space> or selecting Edit»Edit Mode.

5. In the Create Process dialog box, name your process Eval_Server, 
as shown. Leave the rest of the fields with their default settings.

 

6. Click OK.

7. In the New Control Panel dialog box that appears, change the Title 
(not the Name) to Lookout Evaluation Server Control Panel.

8. Click OK.
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9. Select Object»Object Explorer.

Use the Lookout Object Explorer to examine Lookout processes 
running on any Lookout computer on your network, create new 
objects, arrange objects in hierarchical folders, make connections, 
edit data members, and register computers running Lookout on 
your network.

10. Arrange your Lookout workspace so that you can see both your control 
panel and the Object Explorer.

Create a Server ModbusSlave Object

Note These exercises use the ModbusSlave driver object because it does not return errors 
if it cannot locate hardware connected to your serial port. Use the ModbusSlave driver 
object as you would any PLC or RTU driver object.

1. Right-click the Eval_Server process in the Object Explorer, and 
select New Object from the menu. The Select Object dialog box 
appears.

2. Open the Drivers folder and select the ModbusSlave object. Notice 
that a description of this object appears in the field to the right of the 
list of objects.

3. Click OK. The New Modbus Slave dialog box appears, as shown in 
the following illustration. For this example, accept the default values 
for the object ModbusSlave1 by clicking OK.
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The Modbus Slave object, ModbusSlave1, appears under your 
Eval_Server process in the Object Explorer.

Create and Connect a Server Pot Object to Your Modbus Slave
Typically, you do not need to develop the user interface for a server 
process, except for perhaps a few displays to help you verify and 
troubleshoot connections to hardware. The following steps show how to 
add some simple displays. In the Create a Client Process section, you will 
construct a more detailed user interface.

1. Expand the tree view of your newly created ModbusSlave1 object by 
clicking the + sign to the left of it in the Object Explorer, as shown in 
the following illustration. This lets you view the data members 
available for you to use. 

A data member is a data source or sink associated with a Lookout 
object. In the following steps you will display the ModbusSlave 
40001 data member on your control panel. This data member might 
represent a particular hardware register.

2. Right-click the 40001-49999 data member range in Object Explorer 
and drag it to your control panel. Release the mouse button and select 
Create Control»Pot.
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Tip Pot is an abbreviation for potentiometer. In Lookout, you use Pot objects to set or 
control analog outputs.

3. The New Potentiometer dialog box appears, as shown in the 
following illustration. It is connected to 40001 because the first 
available data member is used by default when you select a range.
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4. Accept the default values for Pot1. Click OK. The Insert Pot dialog 
box appears.

5. Select the vertical slider (top row, second graphic).

6. Select the Use as Default checkbox and then click OK. You can 
position your object anywhere on the control panel.

♦ Lookout features easy-to-use drag-and-drop project development.

7. To check that your connection works, place a digital display of the 
ModbusSlave1.40001 data member on your control panel by 
left-clicking 40001-49999 in the Object Explorer and dragging 
it to your control panel.

8. Use the sizing handles around the number to make the display large 
enough to show three digits.



Chapter 3 Try Out Lookout

© National Instruments Corporation 3-9 Lookout Evaluation Guide

9. Select Insert»Text/Plate/Inset and type a percent full label for 
your digital display with a transparent background, as shown in the 
following illustration. Click OK and position the label next to the 
digital display.

 

10. View your process in action. Press <Ctrl-Space> to leave edit mode, 
then use your mouse to move the Pot slider up and down. Notice the 
digital display changes as you move your Pot control, as shown in the 
following illustration. The Pot object output is connected to the 
ModbusSlave1 data member 40001, and the value the Pot sets for 
that data member is shown in the digital display.
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♦ In just a few minutes, you have created and configured a driver object to 
communicate with field hardware, connected a control to that driver 
object, displayed the value of a register, and tested the process.

11. Toggle back to edit mode by pressing <Ctrl-Space>.

12. Select Object»Connection Browser. In the Objects column, 
double-click your computer name, then Eval_Server, then Pot1 to see 
the Pot’s connection to the Modbus Slave 40001 data member in the 
Inputs column. Click Close.

The connection between your Pot control and the Modbus Slave driver is 
an example of a reciprocal (remote source) connection. This connection 
makes the Pot an indicator as well as a control. To have the Pot hold the 
value you set even if something changes the value in your hardware, you 
would use a direct connection. For more information about the various 
types of connections, refer to the Lookout Help.

The digital display is an example of an expression. To learn more, 
right-click the digital display, choose Object Properties, then click the 
Help button in the Revise expression dialog box that appears.

Configure Data for Logging, Scaling, and Alarms
The following steps show how easy it is to configure logging, scaling, 
alarms, and more, for your data. You might want to show how many 
gallons of liquid the tank is holding, display information about the tank and 
its contents graphically, and trigger alarms when the tank is too full or 
almost empty. To keep track of this data and to make it easier to handle, 
Lookout uses the internal Citadel database. Each time you create a Lookout 
object, every one of its data members is a potential entry in this database.

Assume your tank holds 250,000 gallons. You can configure a database 
entry for your tank to track how full the tank is (in gallons), convert the 
percentage measurement to a volume measurement, and handle your 
logging and alarming.

1. Right-click the ModbusSlave1 object in the Object Explorer. Select 
Edit Data Member Configuration. 

2. Using the following illustration for help, enter these values in the 
dialog box.

a. Select the 40001 data member you connected your Pot object to 
by clicking on 40001-49999 in the Native members list. Assign 
it an Alias of TankLevel.
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b. In the Scaling section of the dialog box, set the Raw units at 0 for 
the Minimum and 100 for the Maximum. These are the raw 
numeric values connected to the 40001 data member, indicating 
what percentage of the tank is currently full. Set the Eng. units 
to 0 for the Minimum and 250000 for the Maximum.

Lookout now automatically scales the 0–100 input to a value 
between 0–250,000 that you can display it using the alias value 
TankLevel.

 

c. Check Log to historical database, and set the Lifespan to 5 days.

d. Set the Deviation to 1.5. This part of the configuration will be 
used in the Create a Client Process exercise.

f

a

b

c

d

e
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e. Set your Alarm conditions as shown. Notice that Lookout lets 
you divide alarms into groups, called alarm areas. In this case, 
our alarm Area is Tanks.

Tip For more detailed information on editing data member configuration, click the Help 
button in this dialog box. 

f. Click the Save button (or the Update button if you saved earlier 
in the process), then click the Quit button to exit the dialog box.

♦ Set alarm points, login values, and scaling in one easy dialog box.

3. If necessary, expand the ModbusSlave1 object in the Object Explorer 
by clicking the +, and drag the scaled data member TankLevel to your 
control panel. This digital display reports the contents of your tank in 
gallons.

4. Select Insert»Text/Plate/Inset, and type a gallons label for this 
digital display, choose a transparent background, and click OK. 
Position the label next to the scaled tank level display.

Your control panel should now look similar to the following 
illustration.

 

5. Press <Ctrl-Space> to exit edit mode, then move the Pot slider up and 
down. Moving the Pot to the upper and lower limits of its range triggers 
the alarms you set for TankLevel in step 2e. Notice that the alarms 
appear in the Alarms Window. If you can’t see the Alarms Window, 
select Alarms»Show.

6. Right-click an alarm in the Alarms Window and select Acknowledge 
All to acknowledge the alarms. You can click OK without entering a 
comment.
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7. Save your server process by selecting File»Save. You will be accessing 
it with the client process you create next.

♦ View and acknowledge alarms from any computer on the network.

Tip If you want to change the size and location of the Alarms Window, select Alarms»
Display Options. To control what is displayed in the Alarms Window, select Alarms»
Filter Options. 

Review—Creating a Server Process
A Lookout server process runs on the computer that has direct or physical 
connections to your industrial automation hardware. Configure the data for 
logging, alarms, scaling, and so on in the server process. A server process 
provides data for clients, and does not need an elaborate user interface.

Tip You can add network and local security to this server process. To learn more about 
using the Lookout security features, refer to the Lookout Help.
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Create a Client Process
In this exercise, you build a simple Lookout client process to interact with 
the server you built in the Create a Server Process exercise.

The instructions for this exercise assume you are developing your client 
process on the same computer that is running your server process. In the 
Networking the Client Process section, you will have a chance to move the 
client to a second computer, add a feature, and fix a simulated data quality 
problem.

1. Launch Lookout if it is not already running and load your 
Eval_Server process using the File»Open command.

2. Minimize your server process control panel by clicking the minimize 
box in the upper-right corner of the control panel.

3. Select File»New to create a new Lookout process.

4. In the Create Process dialog box that appears, name your new process 
Eval_Client. Click OK.

5. In the New Control Panel dialog box that appears, change the Title to 
Evaluation Client Control Panel and click OK.

Create a Client Pot Object
1. In the Object Explorer under Eval_Server and ModbusSlave1, 

right-click and drag the 40001-49999 data member range to your 
Eval_Client control panel. Release the mouse button and select 
Create Control»Pot.

The remote connection is defined by a URL, which directs Lookout to 
the target value. Properly configured, this connection works on any 
computer running Lookout on your network.

2. Right-click in the green URL field in the New potentiometer dialog 
box. The following dialog box appears.
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The path \\.\Eval_Server\ModbusSlave1.40001 should work 
as long as your client is running on the same computer you used to 
create your client process—but your goal is to create a process that 
runs from any computer on your network that has Lookout installed. 
For this to be true, you must change the path.

3. Delete the URL string, then assemble a new URL by making the 
following selections in the URL Editor dialog box:

a. Set Path Mode to Absolute. This ensures that your client process 
can locate the data member you are connecting to, no matter what 
computer the client process is run on.

b. Open the Eval_Server process in the left tree view, under your 
computer name, and click ModbusSlave1.

c. Select 40001-49999 in the Contents list. The assembled URL 
\\yourcomputer\Eval_Server\ModbusSlave1.40001 is 
displayed next to the Paste button.
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d. Click Paste to insert the URL string into the green URL field.

Tip For more detailed information on creating and editing URLs, click the Help button in 
this dialog box. 

e. Click OK.

4. Click OK in the New potentiometer dialog box to create the new Pot 
vertical slider object.

5. Press <Ctrl-Space> to leave edit mode. Activate your server process 
control panel by selecting Window»Lookout Evaluation Server 
Control Panel.

6. Arrange your two control panels so you can see both. Operate the Pot 
control in the client process control panel. Notice that on the server 
process control panel, both the Pot control and digital displays 
respond.

7. Operate the Pot control in your server process. Notice that the Pot 
control in your client process changes to reflect movement of the 
server values.

Connect a Client Switch Object to Your Modbus Slave
1. Press <Ctrl-Space> to return to edit mode (the status bar at the bottom 

of the Lookout workspace should turn yellow).

2. Right-click your Eval_Client process in the Object Explorer, and 
select New Object.

3. From the Control folder, select Switch and click OK. The following 
dialog box appears.
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4. For Position Source, select the Remote option, and right-click in the 
green URL field. The URL Editor dialog box appears.

When you created your Pot object for your client, you used a path 
mode to make sure the URL would work from any computer on your 
network. Another way you can ensure portability for this control is to 
change the root of the Signals list box.

5. Expand the Network node in the tree that appears, expand your 
computer under the Network node, then expand the Eval_Server 
process. Select the ModbusSlave1 object as shown in the following 
illustration.

 

6. Select the 1-9999 data member in the Contents list and click Paste to 
insert the URL string into the green URL field.

7. Click OK.

8. Click OK in the New Switch dialog box to finish creating your Switch 
object.
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9. Drag the Switch object from the Object Explorer to your client control 
panel. Select the standard switch on the far right, as shown in the 
following illustration, and click OK.

 

10. In the Object Explorer, expand the ModbusSlave1 object under 
Eval_Server, and drag and drop the 1-9999 data range to your client 
control panel. This inserts an LED display to reflect operation of the 
switch you made.

Note The display you created on the client control panel has a relative path to the Modbus 
Slave data member, a connection that will not work properly if you move the client to 
another computer on your network. Leave it as a relative path so that you can see how 
Lookout monitors data quality and alerts you if the data quality goes bad. You can correct 
the path later in the Correct Problems with Data Quality section.

11. Press <Ctrl-Space> to leave edit mode, and operate the switch you 
placed on your client control panel. 

♦ Connecting to an I/O point across a network is as easy as connecting it 
from the same computer.
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Create a HyperTrend Object
In the Configure Data for Logging, Scaling, and Alarms section, you 
configured the TankLevel data member in your server process for scaling, 
and set it to be logged to Lookout’s Citadel database. As long as your server 
process is running, Lookout is keeping track of this value in Citadel.

1. Make note of the current time on your computer, then change the 
position of the Pot slider on your client or server process a number of 
times in large increments. Later, you will view the changes you made 
on the HyperTrend chart.

2. Press <Ctrl-Space> to return to edit mode.

3. Right-click your Eval_Client process in the Object Explorer and 
choose New Object. Select HyperTrend from the Logging folder and 
click OK.

4. In the Create HyperTrend dialog box, click the Add Group button. 
The following dialog box appears.

 

5. Name the group TankLevels. The default trend width is one minute; 
accept this and the other defaults.
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6. Click OK. Lookout returns you to the Create HyperTrend dialog 
box. Make sure your new TankLevels group is highlighted and then 
click the Add Item button. The following dialog box appears.

7. Set Numeric maximum to 250000 to match the scaled value of the 
data point you are about to display.

8. Right-click in the green URL field to activate the URL Editor. 

9. Set Path Mode to Absolute, then under your computer name in the left 
tree view, select the ModbusSlave1 object in your Eval_Server 
process. Select the TankLevel data member in the Contents list. 
Click the Paste button. The path in the green field should be 
\\yourcomputer\Eval_Server\ModbusSlave1.TankLevel. 
Click OK.

10. Click OK in the Add Item dialog box and again in the Create 
HyperTrend dialog box.

11. Drag your new HyperTrend object from the Object Explorer to your 
client process control panel. Use the sizing handles to adjust the size 
of the chart. Arrange your client process control panel to resemble the 
following illustration. You can add the scale shown by selecting 
Insert»Scale. You can add the Percentage full label by selecting 
Insert»Text/Plate/Inset.
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View Your HyperTrend Data
1. Press <Ctrl-Space> to toggle out of edit mode. Move the Pot slider up 

and down and notice the trace change on the graph.

2. Click the HyperCursor icon in the center of the top of the HyperTrend 
object. The HyperCursor icon is replaced by a solid line down the 
center of the chart, and the HyperTrend1 Cursor dialog box appears, 
as shown in the following illustration.

1 Modbus Slave 1.1 Switch 2 Modbus Slave 1.1 LED Indicator 3 HyperTrend Cursor

2

3

1
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3. Use the Time control on the dialog box to scroll back to the time you 
noted when you changed TankLevel values.

4. Select File»Save All from the Lookout menu to save both your 
processes. Make sure that your client process is saved in the Lookout 
folder, so that you can successfully export it as a Web Client.

♦ You can define as many HyperTrend objects as you want. Each object can 
plot as many numeric (analog) and/or logical values as you want.

Tip Lookout includes another powerful way to view and manage historical data, the 
Historical Data Viewer, which runs in the MAX environment. To explore its capabilities, 
select Options»Historical Data Viewer in Lookout, then click Historical Data in MAX.

Review—Creating a Client Process
A Lookout client process interacts with Lookout servers. It should be 
capable of running on any Lookout computer on your network without 
modification. To ensure this portability, a Lookout client application 
should not include driver objects, and it should always use remote 
connections (or connections through a symbolic link) to a server process.
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Create a Web Client or HTML Report
Lookout offers two choices for making your process data available in 
HTML format. You can generate an HTML report or a Web Client.

With an HTML report, a Web browser can be used to access the 
information you choose to report. The data on a report page is not live; 
it shows a snapshot of the data that is periodically updated according to 
your settings. No downloading is necessary, and operators viewing the data 
are prevented from manipulating the Lookout control objects. 

A Web Client is accessible using a Web browser and the Lookout Player. 
Unlike an HTML report, a Web Client allows you to display and control 
data as any other client process. The data is live and interactive, as you can 
allow operators to manipulate the control objects.

To see how you might create a Web Client, follow the steps in the Create a 
Web Client section. The Create an HTML Report section shows how easy 
it is to create an HTML report.

Create a Web Client
You can create a version of any Lookout process to access using Microsoft 
Internet Explorer. It requires a Windows operating system with Internet 
Explorer 3.2 or later, Lookout software or the Lookout Player installed on 
the client machine, and possibly adjustments for access through a firewall. 
In this exercise you will find out how easy it is to set up a Web Client to 
access and control your process from anywhere in the world.

1. Open Lookout and run your Eval_Client and Eval_Server 
processes. Make sure that your client process is saved in the Lookout 
folder.

2. Press <Ctrl-Space> to put Lookout in edit mode.

3. Select File»Web Server Export Options. The following dialog box 
appears.
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♦ Creating a Web Client is just as easy as exporting your process file.

4. In the Export directory field, enter the complete path to the directory 
on the server computer in which you want to create your Lookout Web 
Client HTML page. All the necessary support files also are placed in 
this directory. If no directory exists on the path you enter, Lookout will 
create one.

• The default root directory for Microsoft Personal Web Server 4.0 
(available on the Windows 98 CD) and Internet Information 
Services 5.0 (shipped with Windows 2000) is C:\Inetpub\
wwwroot. The default root directory for Apache Web Server 1.3 
is C:\Program Files\Apache Group\Apache\htdocs.

• If your computer is not set up as a Web server, you can use 
Microsoft networking to access the Web Client from the remote 
computer. In that case, choose any directory that you can share, 
for example c:\temp.
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5. In the Server URL field, enter the URL for your HTML page.

• If your computer is running Web server software, enter the 
complete Web server path to the page, but do not include the page 
itself. For example, if the complete URL to your page is 
http://webserver/directory/client.html 
enter http://webserver/directory/.

• If your computer is not set up as a Web server, you can use 
Microsoft networking and access the Web Client from the remote 
computer with a fully qualified URL. For example, 
\\server_computer\shared_folder\.

6. Accept the default source for the Lookout Player, the National 
Instruments FTP site at ftp://ftp.ni.com/support/ 
lookout/webclient/5.0/lk50_web.exe. You need the Lookout 
player for any computer without Lookout installed. You will be 
prompted to download it when you attempt to connect to your process 
in Internet Explorer.

7. Click OK.

8. Select File»Export Web Server Files.

9. Select your Eval_Client process for export. Click OK.

You now have an HTML page you can access with a browser. To access 
the page, complete the following steps.

10. Make sure Lookout is running your server process so the Web Client 
has a server to access.

11. If you want to launch the Web Client on the same computer where 
your client process is saved, make sure your client process is closed. 
Lookout cannot open two processes with the same name on a single 
computer. 

12. If you want to access the Web Client using network sharing, make sure 
your export directory on the server computer is shared.

13. Open Internet Explorer on the computer that you want to use to access 
the Web Client.

14. Set the security level option in Internet Explorer to Medium by 
choosing View (or Tools)»Internet Options»Security»Intranet 
if your server is on the same LAN, or Internet if your server is on the 
Internet. If you don’t see the slider with the security levels, click the 
Default Level button. Click OK.
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15. Use Internet Explorer to open the Web Client file. In the URL address 
field, enter the server URL you specified earlier. Open the 
Eval_Client. Click Yes if prompted.

16. When the Web Client launches, maximize the client control panel and 
operate the controls. If you can see your server computer, notice that 
your Web Client controls the server process.

♦ With Lookout, you can easily monitor and control your process using any 
Web browser, without any programming.

Create an HTML Report
You can view an HTML report on any operating system running Internet 
Explorer or Netscape (Netscape does not support Lookout graphic 
formats), without any required adjustments for access through a network 
security firewall. Complete the following steps to make an HTML report 
for one of the examples included with Lookout.

1. On your server computer, select File»Open and open the 
Examples\Applications\continuous2 process.

2. Press <Ctrl-Space> if necessary to switch to edit mode, and create a 
Report object by selecting Object»Create, choosing Report from the 
Logging category folder, and clicking OK twice.

Enter "Continuous Report" as the Title and the Web server root 
directory as the Output directory (for example, "C:\Inetpub\
wwwroot\" for Personal Web Server). If you do not have Web server 
software, you can use folder sharing to expose the report to other 
machines. In that case, enter the path to the shared folder as the Output 
directory, and make sure that folder is shared on the network. Include 
the quotes with these entries, so that the yellow expression fields will 
interpret the information as text. 

3. Enter "default.htm" as the Output file. Include the quotes.

4. Click OK.

5. Select Object»Edit Connections and under continuous2 on your 
computer, choose the Report object. Click OK.

6. In the Report connections dialog box that appears, make the 
following connections:

Report1.HTML1="<META HTTP-EQUIV=""REFRESH"" 

CONTENT=5>"

Choose HTML1-HTML100 in the Writable members field, click 
Select, enter the right side of the equation in the yellow field, then click 
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Accept. This connection makes the browser automatically refresh the 
report page every five seconds.

Report1.Display1=Global_ChemicalFeedPanel.graphic

Choose Display1-Display100 in the Writable members field, 
click Select, enter the right side of the equation in the yellow field, then 
click Accept. This connection puts the main panel on the report page.

Report1.Generate=Pulse(1,0:5,0:1)

Choose Generate in the Writable members field, click Select, enter 
the right side of the equation in the yellow field, then click Accept. 
This connection regenerates the report every five seconds.

7. Click Quit to exit the dialog box.

8. Click the Restore Down button in the top right corner of the panel, 
if necessary, and resize the panel so that it appears as you want it to for 
the HTML report.

9. Save the process as continuous_report.l4p.

10. Open your Web browser and point it to the generated page. In the 
address field enter http://server/ or http://server/
default.htm. If you are using folder sharing, enter 
\\server_oomputer\shared_folder\default.htm.

Review—Creating a Web Client or HTML Report
Lookout allows you to create either a Web Client or HTML report for your 
server process. A Web Client allows you to display and control data. An 
HTML report displays a snapshot of the data that is periodically updated 
according to your settings. 

Networking the Client Process
If you have access to a second computer on your network, you can run your 
new client on that computer and try out Lookout’s easy-to-use networking. 
This exercise shows how a client process developed in a server computer 
can be distributed across any machine in a network. The client process 
works with absolutely no development.

1. Install the Lookout evaluation software on the second computer.

2. Copy your client process files from your first computer to the Lookout 
directory on your second computer. If you did not change the name 
of your process when saving, you should have the following four 
files that comprise your client process: Eval_Client.l4p, 
Eval_Client.l4t, Eval_Client.lks, and Eval_Client.lka.
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3. On your second computer, launch Lookout, close the default process, 
select File»Open, and open Eval_Client. By default, Lookout 
opens a process with the control panels minimized, so activate the 
control panel by clicking the activate button on the minimized menu 
bar at the bottom of the Lookout workspace.

4. Operate the Pot object slider on your second computer. The Pot 
controls in your server and original client processes (running on your 
server computer) should respond.

5. Notice the red X over the LED indicator, which indicates a data quality 
problem. This will be explained later in the Correct Problems with 
Data Quality section.

Note If you do not see any traces on your HyperTrend, you may need to synchronize your 
computers. This will be explained later in the Synchronize Computer Clocks section.

Register Your Network Computers
While Lookout processes can communicate with each other across the 
network without any special preparations, you must register all other 
computers running Lookout if you want to browse across the network 
for development purposes.

1. On the second computer, press <Ctrl-Space> to put Lookout in edit 
mode. Select Object»Object Explorer if the Object Explorer is not 
already running.

2. Click the name of your second computer in the window at the top of 
the Object Explorer, and select Universe from the pull down list. 

You now can browse every computer registered as running Lookout on 
your network.

3. Register your server computer (the one running your server process) 
here by right-clicking Network and selecting Register computer.
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4. In the Register Network Computer dialog box that appears, enter the 
name of your server computer into the Computer name field, as 
shown. If you prefer, you can browse for your computer name in the 
network tree view available in the Entire Network field.

 

5. Click OK.

6. Expand the Network node of the tree view in the Object Explorer. You 
should see both your second computer (the computer you are currently 
working on) and the computer running your server process, as shown 
in the following illustration.
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♦ With Lookout you can log data to any computer on your network, and 
retrieve data from any computer.

Correct Problems with Data Quality
The red X superimposed on the second computer’s LED indicator is an 
example of the Lookout data quality feature, which alerts you when your 
process is receiving data that has some problem. Complete the following 
steps to fix the data quality problem.

1. On the second computer, delete the display with the data quality alert 
(red X) over it from your client control panel by clicking it and 
pressing the <Delete> key.

2. Expand the Object Explorer tree view so that you can see the processes 
running on your server computer and the ModbusSlave1 object, as 
shown in the following illustration.

 

3. Drag the 1-9999 data member under the Eval_Server Modbus 
Slave object to your client control panel. Notice that the new display 
object no longer shows the data quality alert (red X).

4. Press <Ctrl-Space> to exit edit mode and operate your switch. If you 
can see your server computer, you should notice that the displays on 
the server computer control panels respond.

5. Select File»Save to save your changes.

♦ With Lookout, networking is as easy as using Windows Explorer.
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Synchronize Computer Clocks
You might notice some time lag in operating your Pot control and seeing 
the change in your HyperTrend chart on your server computer, which 
can happen when your networked computers do not have their clocks 
synchronized. To provide for accurate data logging, complete the following 
steps to have Lookout synchronize your computers.

1. On the second computer, select Options»Time Synchronization from 
the Lookout menu bar. The following dialog box appears.

 

2. Click Add. The Add Time Server dialog box appears.

3. Enter the name of your server computer in the Computer name field. 
You also can browse for your computer in the Entire Network list.

4. Click OK. The Time Synchronization Settings dialog box reappears.

5. Set Sleep Time to 300. With this setting, your computers 
resynchronize every five minutes.

6. Click OK. Your computers are now synchronized.

7. Select File»Save to save your changes.
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Show Networked Alarms and Events
If you operate your Pot slider on your server computer, you may notice that 
the alarms you trigger on your server computer do not appear in the Alarms 
window on your second computer. To monitor and acknowledge alarms 
from a networked computer, you must select the processes you want to 
monitor as follows.

1. On your second computer, select Alarms»Select Processes in 
Lookout. The following dialog box appears.

 

2. Expand the tree view to show the processes running on your server 
computer. Select the Eval_Server process, and click the Add button. 
Click OK.

Your second computer now can monitor alarms from your server 
computer.

3. Select File»Save to save your changes.

♦ Connect to alarms across a network in one easy step.



Chapter 3 Try Out Lookout

© National Instruments Corporation 3-33 Lookout Evaluation Guide

Review—Networking
Networking a Lookout application is as easy as copying your client process 
files to any networked computer. Then you can use simple Lookout dialog 
boxes to resolve any data quality problems, synchronize your system 
clocks, register computers, and access alarm and event information.
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4
Where to Go from Here

This chapter introduces you to the demonstration processes and additional 
features included with your Lookout software, and describes how to 
uninstall your Lookout evaluation software. It also includes information 
to help you contact National Instruments to learn more about Lookout and 
other National Instruments products.

Exploring Additional Lookout Features
There are many more features in Lookout other than the ones covered in 
this guide. Some of the other major capabilities of Lookout are statistical 
process control, batch management, sequential process management, 
complex expressions, data tables, animated graphics, Aggregate objects, 
advanced security across networks, and connectivity with other National 
Instruments software. These, along with a host of other capabilities that are 
beyond the scope of this guide, make Lookout one of the most powerful 
software packages available on the market.

The evaluation copy of Lookout comes with the full Lookout Help system, 
which contains information on all the Lookout objects, features, and 
services.

If you haven’t yet explored the application examples, you can do so by 
selecting File»Open and browsing the Examples directory.

Uninstalling the Lookout Evaluation Software
To uninstall your evaluation copy of Lookout, first exit Lookout, then stop 
the NI Services by right-clicking the NI Service Manager icon in the task 
tray next to the computer clock and selecting Stop all services. Then select 
Start»Settings»Control Panel»Add/Remove Programs, highlight the 
NI Lookout entry, and choose to remove it. 
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Lookout also installs portions of NI software that may be shared. If you 
have other NI software installed, you may want to leave these shared 
components; otherwise, remove them individually.

• NI DSC Common Tools

• NI Historical Data Viewer

• NI Logos

• NI Measurement & Automation Explorer

• NI Server Explorer

When the uninstall process is complete, you might receive a message that 
some components could not be uninstalled. These files include database 
files for data you logged during the demonstrations and any process files 
you created. You can delete these files manually from your Lookout 
directory.

Purchasing Lookout
For more information about Lookout and other National Instruments 
industrial automation products, visit the National Instruments Web site at 
ni.com/lookout. You also can email your questions to info@ni.com.

Your local National Instruments representative can supply information 
tailored to your needs. If you are not already in contact with a representative 
for your area, call National Instruments at 512 683 0100 to have your 
questions answered.

Thank you for your interest in Lookout.
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 
and interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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